[phpBB Debug] PHP Notice: in file [ROOT]/ext/unilang/languages/includes/lang_functions.php on line 403: Undefined property: unilang/languages/includes/lang_data::$country_names_en
[phpBB Debug] PHP Notice: in file [ROOT]/ext/unilang/languages/includes/lang_functions.php on line 403: Undefined property: unilang/languages/includes/lang_data::$country_names_en
[phpBB Debug] PHP Notice: in file [ROOT]/ext/unilang/languages/includes/lang_functions.php on line 424: Undefined property: unilang/languages/includes/lang_functions::$regionsdata
[phpBB Debug] PHP Notice: in file [ROOT]/ext/unilang/languages/includes/lang_functions.php on line 424: Trying to get property of non-object
[phpBB Debug] PHP Notice: in file [ROOT]/ext/unilang/languages/includes/lang_functions.php on line 403: Undefined property: unilang/languages/includes/lang_data::$country_names_en
[phpBB Debug] PHP Notice: in file [ROOT]/ext/unilang/languages/includes/lang_functions.php on line 403: Undefined property: unilang/languages/includes/lang_data::$country_names_en
[phpBB Debug] PHP Notice: in file [ROOT]/ext/unilang/languages/includes/lang_functions.php on line 403: Undefined property: unilang/languages/includes/lang_data::$country_names_en
[phpBB Debug] PHP Notice: in file [ROOT]/ext/unilang/languages/includes/lang_functions.php on line 403: Undefined property: unilang/languages/includes/lang_data::$country_names_en
[phpBB Debug] PHP Notice: in file [ROOT]/ext/unilang/languages/includes/lang_functions.php on line 424: Undefined property: unilang/languages/includes/lang_functions::$regionsdata
[phpBB Debug] PHP Notice: in file [ROOT]/ext/unilang/languages/includes/lang_functions.php on line 424: Trying to get property of non-object
日本語のフォント (Japanese Fonts) [Under construction] - Page 2 - UniLang

日本語のフォント (Japanese Fonts) [Under construction]

Moderator: hashi

User avatar
ego
Posts: 4917
Joined: 2004-12-06, 15:19
Real Name: Thanasis
Gender: male
Location: SX
Country: GB United Kingdom (United Kingdom)

Re: 日本語のフォント (Japanese Fonts) [Under construction]

Postby ego » 2009-11-19, 13:43

Grazie :D

User avatar
meidei
Posts: 6119
Joined: 2010-08-08, 19:56
Country: CY Cyprus (Κύπρος / Kıbrıs)

Re: 日本語のフォント (Japanese Fonts) [Under construction]

Postby meidei » 2011-04-23, 13:53

Something is wrong with my japanese fonts today, after a system update. On Firefox and Gwibber (twitter client), the KANA sets are messed up. For example, "fonto" in the title appears as "byowode" in katakana, the middle dot appears as a katakana WO with dakuten, the long vowel mark in katakana appears as a middle dot, katakana N appears as a WO, hiragana normal I appears as hiragana small I, hiragana JI as hiragana ZA etc

Well, I am sure I just have to change my selected fonts and it will be fine. It's weird though. How did they managed to break a whole font family with a single software update...
Knows:Cypriot Standard Greek & Cypriot Spoken Greek (el-cy)| (en)|Standard Greek - Greece's Written Standard (el)
Attempting:  (tr) (sgn-CY)
Resuming shorty: (fr)
Forgetting: (ja)

User avatar
cumberbatch
Posts: 33
Joined: 2013-04-10, 11:07
Gender: female
Location: Quezon City
Country: PH Philippines (Pilipinas)

Re: 日本語のフォント (Japanese Fonts) [Under construction]

Postby cumberbatch » 2013-04-23, 11:54

This happened to me too. Japanese fonts won't show up properly in my PC. I tried downloading the service pack for Asian languages, that didn't solve the issue. Eventually I gave up already and used another PC.

User avatar
Youngfun
Language Forum Moderator
Posts: 2358
Joined: 2012-12-08, 7:19
Real Name: Francesco
Gender: male
Country: CN China (中国)

Re: 日本語のフォント (Japanese Fonts) [Under construction]

Postby Youngfun » 2013-04-23, 14:54

I've never had problems with East Asian fonts on XP... :ohwell:

Ayiaearel wrote:Installing Japanese Fonts

Windows XP
1. Open the Control Panel.

2. Click Date, Time, Language, and Regional Options and then Regional and Language Options (if the Control Panel is in in Classic View, just click Regional and Language Options).

3. Click the Languages tab.

4. Check the Install East Asian Languages box and then click Apply .

5. Click the Details button.

6. Click Add.

7. In the Add Input Language dialog box, select Japanese

8. In the same dialog box, select Microsoft IME Standard 2002 ver. 8.1 and click OK.

9. You should now have Japanese under Installed Services.

10. Click OK.

And here you forgot to mention that you need a XP CD, or a CD image (iso)... :ohwell:
Or just the extracted i386 folder...

The procedure is OK if you only need to surf Japanese sites, and deal with Japanese texts.
But if you also use Japanese programs (non-Unicode) you'll need additional steps:
10. Click OK Apply.

11. Click the Advanced tab.

12. From the drop down menu select Japanese.

13. Click OK.

But beware: with this setting some installers will automatically choose Japanese language. So do it only if you're fluent in understanding Japanese texts.
This will also cause problems for the applications, such as not displaying correctly diacritics and non-Latin characters.

If you need to use both Japanese and non-Latin alphabets programs, and they have trouble displyaing characters, you'll need AppLocale.

Everything I said is valid on XP. I'm not familiar with other O.S.

Hoping that in future programmers will be wiser to write programs in Unicode.


Return to “Japanese (日本語)”

Who is online

Users browsing this forum: No registered users and 1 guest

cron